Author Topic: brittle fuel connectors  (Read 4423 times)

0 Members and 1 Guest are viewing this topic.

June 18, 2016, 06:03:48 PMReply #15 on

Offline adetheblade (OP)

  • Tiger Cub
  • Posts: 11
  • Activity Meter:
    0%
  • nOObie
  • LOCATION: risca gwent
thanks for replies guys, Tim..yep fuel pump primed and filled fuel lines ok, Joe......my thinking too, maybe one of the injectors if i was that unlucky, but surely not all in one hit, unless blockage was at the end of fuel rail, then starving all injectors, don`t know at a loss until i open her back up perhaps. cranked her over more than enough to fill / pressurize lines, rail etc. running fine after i did throttle balance, then snapped connector and chaos since !! just my luck. :m Ade

June 18, 2016, 08:33:53 PMReply #16 on

Offline Bixxer Bob

  • Cool Cats
  • Chatty Cathy
  • *
  • Location: Norfolk, England
  • Posts: 5889
  • Activity Meter:
    0%
  • I make the mistakes so you don't have to.....
  • LOCATION: Norfolk, England
HEre we go   :icon_rolleyes:, memory refresher, and only my thoughts as mine's in bits at the moment.

Kill switch cuts dash lights and it wo't turn over.

Cluch switch stops it turning over.

Side stand switch allows it to turn over but not fire.

Discuss  :icon_study:
I don't want to achieve immortality through prayer, I want to achieve it through not dying...

June 18, 2016, 08:43:15 PMReply #17 on

Offline Bixxer Bob

  • Cool Cats
  • Chatty Cathy
  • *
  • Location: Norfolk, England
  • Posts: 5889
  • Activity Meter:
    0%
  • I make the mistakes so you don't have to.....
  • LOCATION: Norfolk, England
IF your bttery is down on power, it will crank ok, but the injectors don't fire (something else I've done so you don't have to....)  Since you're going back in there it's n esy check, just whip the airbox off and look down the TBs with the butterflies open while you crank.

You could look at TuneECU  for injector pulse in diagnostices, but I don't know if that will tell you whether the injectors are actually firing or only that the ECU is sending a pulse.
I don't want to achieve immortality through prayer, I want to achieve it through not dying...

June 20, 2016, 07:16:15 PMReply #18 on

Offline adetheblade (OP)

  • Tiger Cub
  • Posts: 11
  • Activity Meter:
    0%
  • nOObie
  • LOCATION: risca gwent
hello all, just another update...... taken all fuel system apart ( fuel rails / injectors / fuel pump assembly ) cant see anything obvious.all hoses inside tank were in place etc. sprayed carb cleaner into TB and she fired straight away ( fuel delivery problem confirmed. ) injectors / fuel rail internals were dryish . i think the problem is pump end, reason being, i dont get any pressurised spurting from feed pipe when i disconnect from tank after priming system. pump is making all the right noises but maybe not doing its job correctly. something else that caught my eye was filter is oe triumph one with a possible date stamp on it ( 16.03.01 ) if thats right then its possibly the original filter ( which i will renew with a mahle anyway). next question is do i buy a new pump and be done with it ? cheers Ade

June 20, 2016, 07:43:20 PMReply #19 on

Offline Timbox2

  • Sumatran Tiger
  • *
  • Location: South Wales, UK
  • Posts: 2115
  • Activity Meter:
    0.22%
Funny mate, mine went (Pump) not long after I bought it, and weirdly when I was also doing similar stuff to you, replacing Q/R's etc. I bought a complete S/H pump and plate off ebay for £50. I notice that you can buy brand new pattern pumps for less than that but I wasnt sure how good they are and if they are truly plug and play. Oh yeah, mine made all the right noises too, but on testing it there was no pressure
2016 Tiger Sport

June 20, 2016, 07:47:49 PMReply #20 on

Offline JoeDirt

  • Mad Scientist
  • Cheetah
  • Location: USA - MA
  • Posts: 591
  • Activity Meter:
    0%
  • Life's a garden... dig it!
question is do i buy a new pump and be done with it ? cheers Ade

It would be a "peace of mind" purchase... ebay.UK has them for http://www.ebay.co.uk/itm/262386212466

About the same price as a filter...  http://www.ebay.co.uk/itm/300938753392

June 20, 2016, 08:19:50 PMReply #21 on

Offline adetheblade (OP)

  • Tiger Cub
  • Posts: 11
  • Activity Meter:
    0%
  • nOObie
  • LOCATION: risca gwent
Funny mate, mine went (Pump) not long after I bought it, and weirdly when I was also doing similar stuff to you, replacing Q/R's etc. I bought a complete S/H pump and plate off ebay for £50. I notice that you can buy brand new pattern pumps for less than that but I wasnt sure how good they are and if they are truly plug and play. Oh yeah, mine made all the right noises too, but on testing it there was no pressure

uncanny eh ! what im gonna do Tim is drop the pump into a jug of fuel with a pipe connected. test it from a seperate battery just to see what pressure if any is there just to satisfy myself its shot ! (ran out of time tonight ) will buy a pump and filter anyway, just a curious boy thats all. thanks for input mate :icon_salut:

June 20, 2016, 08:23:04 PMReply #22 on

Offline adetheblade (OP)

  • Tiger Cub
  • Posts: 11
  • Activity Meter:
    0%
  • nOObie
  • LOCATION: risca gwent
It would be a "peace of mind" purchase... ebay.UK has them for http://www.ebay.co.uk/itm/262386212466

About the same price as a filter...  http://www.ebay.co.uk/itm/300938753392

thanks for the links Joe, just had a peek and will be pry-barring my wallet open anytime soon. thanks for help mate. :*

June 20, 2016, 10:00:45 PMReply #23 on

Offline Sin_Tiger

  • I have the POWER !
  • Cool Cats
  • Chatty Cathy
  • *
  • Location: Singapore / Scotland
  • Posts: 5571
  • Activity Meter:
    0%
  • Max the Moderator
If your pump checks out OK, make sure the new connectors are pushed well home, being new they will be stiff.
I used to have long hair, took acid and went to hip joints. Now I long for hair, take antacid and need a new hip joint

June 26, 2016, 04:21:34 PMReply #24 on

Offline adetheblade (OP)

  • Tiger Cub
  • Posts: 11
  • Activity Meter:
    0%
  • nOObie
  • LOCATION: risca gwent
back again...new pump and filter fitted, running like a champ ! old pump was tested and was very weak, filter wasnt really clogged as such. there ya go ! next question is i`ve fitted an aftermarket open can this week and have loaded up a 10121 map. having read Mats new iacv setting thread, my old map 10120 (factory can ) had an iacv value of just 2, and when i loaded in the 10121 map that gave an initial value of -3 :bug_eye. as BB has suggested to Mat, do i gradually (hopefully) creep that figure up as close to 35 as poss ? pick up and back to idle seem reasonably good :m thanks again all. Ade

June 26, 2016, 04:56:10 PMReply #25 on

Offline Timbox2

  • Sumatran Tiger
  • *
  • Location: South Wales, UK
  • Posts: 2115
  • Activity Meter:
    0.22%
back again...new pump and filter fitted, running like a champ ! old pump was tested and was very weak, filter wasnt really clogged as such. there ya go ! next question is i`ve fitted an aftermarket open can this week and have loaded up a 10121 map. having read Mats new iacv setting thread, my old map 10120 (factory can ) had an iacv value of just 2, and when i loaded in the 10121 map that gave an initial value of -3 :bug_eye. as BB has suggested to Mat, do i gradually (hopefully) creep that figure up as close to 35 as poss ? pick up and back to idle seem reasonably good :m thanks again all. Ade

If its running ok I would leave it alone, see my post from yesterday on Mats thread
2016 Tiger Sport

June 26, 2016, 06:03:54 PMReply #26 on

Offline Bixxer Bob

  • Cool Cats
  • Chatty Cathy
  • *
  • Location: Norfolk, England
  • Posts: 5889
  • Activity Meter:
    0%
  • I make the mistakes so you don't have to.....
  • LOCATION: Norfolk, England
Agreed. If it's running ok leave alone. 

Mine used to run very low numbers till I found a tiny leak on one ICV pipe.  (think about it, it the numbers are low then the air must be coming from somewhere else).  Hopefully I'll have mine running again tomorrow so I'll have a better idea then.
I don't want to achieve immortality through prayer, I want to achieve it through not dying...

June 27, 2016, 07:44:44 AMReply #27 on

Offline Chris Canning

  • Sumatran Tiger
  • *
  • Location: Birmingham England
  • Posts: 3909
  • Activity Meter:
    1.56%
I've 2 bikes that have PC's fitted and another with a Rexxer map they run exactly as the day they were set up years ago,the 955!!! I never know what the hell it is going to do,I've had maps blown into it at dealers and 6 months down the line different again and not laid a finger on it and since the stepper went belly up the bike has a mind of its own at tickover but once the clutch is out runs as well as it ever has.

Fine for us long termers who are used to its quirks god knows what new owners make of them :icon_scratch: